라인은에 해당되는 글 1건

Textcube 1.8 beta 5 공개

Category : 업데이트/테스트 버전
Reg Date : 2009/07/22 00:53

Textcube (이하 텍스트큐브) 1.8의 다섯번째 베타버전 (1.8.7756.20090722)을 공개합니다. 새 프레임웍 및 서비스 영역에 관련한 여러 문제로 인하여 텍스트큐브 1.8 alpha 8 이후 4개월동안 베타 트리의 업데이트가 현재까지 연기되었습니다.

텍스트큐브 1.8부터 도입 예정이었던 새 프레임웍인 NAF2 의 본격적인 도입은 텍스트큐브 2.0으로 연기되었으며, 텍스트큐브 1.8은 NAF2가 일부 반영되었지만 기존의 프레임웍과 호환성이 있는 NAF 호환 (1.5?) 프레임웍을 사용합니다. (NAF2는 리팩토링 중 성능 문제가 발견되어 재설계 중입니다.)

텍스트큐브 1.8은 텍스트큐브 1.7을 기반으로 새로운 환경에 대응하기 위한 텍스트큐브 2.0 이전의 버전입니다. 원래 예정되었던 텍스트큐브 2.0 로드맵 이전에 텍스트큐브 2.0이 설치되기 위한 제반 환경의 구축 및 홍보를 위한 버전입니다.

텍스트큐브 1.8은 1.7 코어의 하부 구조를 새로운 기반인 PHP 5.2 / MySQL 4.1의 기능을 충분히 활용하여 개선함과 동시에 대량 트래픽에 대한 대응 및 다양한 데이터베이스 지원과 텍스트큐브 2.0 프레임웍의 일부 테스트를 목표로 합니다.

주의사항

이 버전은 테스트를 위한 버전입니다. 관련한 인터페이스 및 코드 규격은 언제든지 변경될 수 있습니다. 또한 안정성에 대한 검증이 되지 않은 버전입니다. 실제 사용하는 블로그에는 적용하지 않는 것을 권장합니다.

업그레이드 하신 경우 반드시 블로그 주소 끝에 /checkup을 붙여서 데이터베이스 구조를 변경하시기 바랍니다. 그렇지 않으면 정상적으로 동작하지 않습니다.

또한 텍스트큐브 1.8은 PHP 5.2 이하의 버전에서 정상적으로 동작하지 않을 수 있습니다. 설치하는 서버의 PHP 버전이 5.2 이상인지 반드시 확인하시기 바랍니다.

텍스트큐브 1.8의 대부분의 기능 변경점과 버그 수정은 텍스트큐브 1.7.8에 백포트되어 선반영 된 상태입니다. 아래는 텍스트큐브 1.8에서 고유하게 변경된 내용입니다.

텍스트큐브 1.7.8 코어와 비교하여 텍스트큐브 1.8 beta 5에서 변경된 점은 다음과 같습니다.

  • 하부구조가 변경되었습니다. 업그레이드 형식으로 테스트할 경우 기존의 스킨이 보이지 않을 수 있습니다. 스킨을 포함한 구성요소들의 위치가 모두 변경되었습니다.
    • 블로그 스킨의 경우 /skin/blog 디렉토리로,
    • 관리 패널 스킨의 경우 /skin/admin 디렉토리로,
    • 카테고리 트리 스킨의 경우 /skin/tree 로 변경되었습니다.
    • 기존에 사용하시던 스킨은 해당되는 디렉토리로 이동해 주시기 바랍니다.
  • 언어팩 구조가 바뀌었습니다. 언어팩 위치는 /resources/locale 하위의 국가 코드 아래입니다. 부하를 줄이기 위하여 언어팩이 네 개로 분리되었습니다. 확인해 보시기 바랍니다.
  • memcached를 이용한 가속을 지원합니다. 이 기능을 사용하기 위해서는 서버 설정에서 memcache 사용을 체크하시면 됩니다. 기본값 이외의 memcached 설정을 위해서는 config.php에서 $memcached 변수를 통해 세부 사항을 지정할 수 있습니다. 가능한 값으로는 $memcached['port'], $memcached['server'] 값이 있습니다
  • memcached를 이용한 세션 핸들링을 지원합니다. memcache를 사용하는 경우 세션은 자동으로 memcache를 사용하도록 지정됩니다.
  • MySQLi를 사용한 데이터베이스 연결을 지원합니다. MySQLi를 지원하는 시스템에서는 자동적으로 MySQLi를 사용합니다.
  • Nginx 웹서버를 지원합니다. Nginx 웹서버는 러시아에서 개발된 가볍고 빠른 웹서버입니다. Nginx 웹서버와 fastCGI 의 조합 또한 지원합니다. 자세한 설치 방법은 배포판의 documents 하위의 nginx 관련 문서를 참고하시기 바랍니다.

아래는 변경사항 기록입니다.

more..

IIS / Nginx 웹서버 지원

텍스트큐브 1.7.6 이후의 버전은 IIS를 지원합니다. 또한 텍스트큐브 1.8부터 공식적으로 Nginx 웹서버의 설치를 지원합니다. 설치 및 설정에 관한 내용은 소스에 포함되어 있는 /documents/INSTALL 및 setup_nginx.txt 문서를 참고하시기 바랍니다..

스킨 치환자 추가

카테고리 피드 지원

텍스트큐브 글 내에서 현재 글의 같은 카테고리 내의 최근 글을 출력하는 치환자가 두 개 추가 되었습니다.

  • [##_article_rep_category_rssurl_##] : 카테고리 RSS 의 링크입니다.
  • [##_article_rep_category_atomurl_##] : 카테고리 ATOM 의 링크입니다.

또한 블로그 설정에서 카테고리 출력 부분에도 RSS 링크를 출력할 수 있는 옵션이 추가되었습니다. 이 옵션을 사용하기 위해서는 현재는 해당 카테고리 부분의 디자인이 스킨에 반영되어 있어야 합니다. 기본적으로 포함되어 있는 coolant 스킨의 디자인을 참조하시기 바랍니다.

라인 기능 추가

텍스트큐브에 빠르게 글을 적는 기능인 라인 기능이 추가되었습니다. 이를 지원하기 위한 스킨 문법이 추가 되었습니다.

  • s_line 영역
    • [##_line_rssurl_##] : 라인의 RSS 피드 주소입니다.
    • [##_line_atomurl_##] : 라인의 ATOM 피드 주소입니다.
    • s_line_rep 반복 영역
    • [##_line_rep_regdate_##] 라인의 등록 시간. 현재 시간부터 얼마 전을 보여줍니다.
    • [##_line_rep_content_##]라인의 내용.

사용된 예제는 기본 스킨인 coolant를 참고하시기 바랍니다. 정식 발표 전까지 다른 치환자들이 추가될 수 있으므로, 관련하여 의견을 포럼에 남겨주시면 검토 후 추가하도록 하겠습니다.

피드백

테스트 중 개선에 대한 건의 사항이나 버그 보고는 태터 네트워크 재단 / 태터앤 프렌즈 포럼 의 아이디어 포럼이나 버그 보고 및 품질 검수 포럼으로 부탁 드립니다.

소스에 대하여 궁금하거나 변경사항을 추적하고 싶은 분들께서는 텍스트큐브 소스 내의 doc 디렉토리에 여러 문서들이 있으므로 참고하시기 바랍니다.

아래의 링크에서 다운로드 할 수 있습니다.

2009/07/22 00:53 2009/07/22 00:53

Posted by 텍스트큐브

이 글의 관련글(트랙백) 주소 : 이 글에는 트랙백을 보낼 수 없습니다
  • Tracked from : Louice Studio Inc. 2009/07/25 02:26 DELETE
    Subject : Japanisches Lokalisierung für Textcube

    Japanese Locale for Textcube 1.8.x textcube_jaloc_rev9a2_20090726.7zJapanisches Lokalisierung für Textcube 1.8.x (7z) textcube_jaloc_rev9a2_20090726.zipJapanisches Lokalisierung für Textcube 1.8.x (zip)---------- textcube_jaloc_rev9a2_20090726_localeon...

Comments
  1. 도아
    2009/07/22 19:08  PERMALINK  MODIFY/DELETE  REPLY

    수고 많으셨습니다. 그런데 설치하려고 하니 또 오류군요.

    Fatal error: Cannot redeclare _t_noop() (previously declared in /web/home/doax/html/framework/legacy/Needlworks.Core.Locale.php:291) in /web/home/doax/html/library/locale.php on line 9

    setup.php에서 locale.php 를 include 하는 부분을 주석처리하고 설치를 진행하면 4단계에서 5단계로 넘어가며

    Warning: Autoload::require_once(./framework/legacy/Needlworks.DBMS..php) [function.Autoload-require-once]: failed to open stream: No such file or directory in /web/home/doax/html/framework/legacy/Needlworks.PHP.Loader.php on line 87

    Fatal error: Autoload::require_once() [function.require]: Failed opening required './framework/legacy/Needlworks.DBMS..php' (include_path='.:/usr/local/lib/php') in /web/home/doax/html/framework/legacy/Needlworks.PHP.Loader.php on line 8

    와 같은 오류가 발생합니다.

    • 텍스트큐브
      2009/08/05 14:56  PERMALINK  MODIFY/DELETE

      오늘 1.8 b6을 업로드 하였습니다. 텍스트큐브의 프레임웍인 NAF1을 PHP 5.2 대응인 NAF2의 프로토타입으로 넘어가면서 하부 구조가 엄청 바뀌었습니다. 그 과정에서 레거시 코드들에 대한 대응 부분이 1.7.9 트리와 엉켜서 발생한 문제입니다.

      1.8 b6에서는 거의 모든 문제가 해결 되었으므로 테스트 부탁 드립니다.^^

  2. Rukxer
    2009/07/27 22:21  PERMALINK  MODIFY/DELETE  REPLY

    Warning: require(./library/locale.php) [function.require]: failed to open stream: No such file or directory in /home/hosting_users/rukxernet/www/setup.php on line 55

    Warning: require(./library/locale.php) [function.require]: failed to open stream: No such file or directory in /home/hosting_users/rukxernet/www/setup.php on line 55

    Fatal error: require() [function.require]: Failed opening required './library/locale.php' (include_path='.:/usr/local/lib/php') in /home/hosting_users/rukxernet/www/setup.php on line 55


    이런 에러가 뜨는데 ㅜㅡ 우찌할까요 ㅜㅡ

    • 텍스트큐브
      2009/08/05 15:00  PERMALINK  MODIFY/DELETE

      오늘 발표한 b6을 테스트 해 보시기 바랍니다^^

COMMENT*