요구사항에 해당되는 글 1건

텍스트큐브 1.7 이후 서버 요구사항 확정 안내

Category : 기타/TNF
Reg Date : 2008/06/18 23:36

안녕하세요.

작년 12월부터 텍스트큐브 2.0 의 구조 설계 및 요건 정리 논의가 진행 중입니다. 엔진을 교체하기 위해서는 차체를 갈아야 한다는 의견이 계속 있어 왔습니다. 서버 지원 사양의 변경이 논의되었습니다. 논의 결과에 따라 관련하여 텍스트큐브 1.7 이후의 서버 요구사항을 미리 알려 드립니다.

  • Apache 1.2 이상 / PHP 5.2 이상 / MySQL 4.1 이상 (논의중)

PHP 4.3의 경우 2007년 말 이후 더이상 PHP.net 에서 지원하지 않기 때문에 고려 대상에서 제외하였습니다.

또한 MySQL 3 지원을 위한 제약 조건으로 텍스트큐브 전체의 속도가 영향을 받고 있는 점을 개선하기 위하여 MySQL은 최소 4.1 이상을 지원할 예정입니다. MySQL 4.1 이상 요건의 경우, 추상화 단계에 대한 논의 과정에 따라 MySQL 5.0 또는 5.1 이상을 요구하게 될 수 있습니다. MySQL 4.1이 요건으로 지정되는 경우에도, MySQL 5.1 이상에서는 텍스트큐브 프레임웍의 성능 향상이 있을 예정입니다.

텍스트큐브 2.0의 일정이 8월 16일로 얼마 남지 않았기 때문에 텍스트큐브 1.7 과 텍스트큐브 2.0 사이의 중간 연결을 위하여 텍스트큐브 1.8을 개발 일정에 넣을 가능성이 있습니다. 텍스트큐브 1.8은 1.7의 기능에 PHP 5.2와 MySQL 4.1 이상에 최적화된 코드와 함께 2.0 에 도입될 텍스트큐브 어플리케이션 프레임웍 2의 일부 기능을 테스트하는 버전이 될 것입니다.

텍스트큐브 1.7.X 의 요구사항은 이전과 동일한 Apache 1.2 이상 / PHP 4.3 이상 / MySQL 3.23 이상 입니다.

텍스트큐브를 사용하기 위해서 서버를 설정하거나 호스팅 서비스를 알아보시는 분들은 참고해 주시기 바랍니다.

2008/06/18 23:36 2008/06/18 23:36

Posted by 텍스트큐브

이 글의 관련글(트랙백) 주소 : 이 글에는 트랙백을 보낼 수 없습니다
  • Tracked from : (LocoMo) Forge 2008/06/26 20:41 DELETE
    Subject : 텍스트큐브와 호환성 전쟁

    http://notice.textcube.org/ko/127예전 태터툴즈가 버전 1을 찍으면서 UTF-8 인코딩을 지원하는 MySQL 서버들이 대폭 늘어난 기억이 납니다. 하지만 데이터베이스에서 UTF-8 인코딩을 못하는 서버라도 문제없이 잘 돌아갔습니다. 아마 그 힘은, 제가 알기로는 함수 딱 하나만을 담은 iconv.php라는 참 커다란 파일에서 나왔다고 생각합니다.그러니 당연히 잘 돌아갔습니다. 뒤에서 100KB 스크립트 파일이 함수 딱 하나...

Comments
  1. 컴ⓣing
    2008/06/19 21:17  PERMALINK  MODIFY/DELETE  REPLY

    오늘도 수고에 감사드립니다..^^

  2. Downright
    2008/06/19 22:12  PERMALINK  MODIFY/DELETE  REPLY

    덕분에 블로그를 잘 이용하고 있습니다. 감사드립니다.
    두달 사이에 많은 업데이트가 계획되어 있군요.
    더운 날씨에도 수고 많으십니다.^^

  3. 유라기
    2008/06/20 10:28  PERMALINK  MODIFY/DELETE  REPLY

    블러그 보러 왔습니다.
    싸이트 정말 이쁩니다.

COMMENT*