1.8에 해당되는 글 14건

Textcube 1.8 beta 4 공개

Category : 업데이트/테스트 버전
Reg Date : 2009/06/24 01:16
Textcube 1.8: Requiem

노무현 전 대통령님의 명복을 빕니다.

Textcube (이하 텍스트큐브) 1.8의 네번째 베타버전 (1.8.7669.20090624)을 공개합니다. 새 프레임웍 및 서비스 영역에 관련한 여러 문제로 인하여 텍스트큐브 1.8 alpha 8 이후 4개월동안 베타 트리의 업데이트가 현재까지 연기되었습니다.

텍스트큐브 1.8부터 도입 예정이었던 새 프레임웍인 NAF2 의 본격적인 도입은 텍스트큐브 2.0으로 연기되었으며, 텍스트큐브 1.8은 NAF2가 일부 반영되었지만 기존의 프레임웍과 호환성이 있는 NAF 호환 (1.5?) 프레임웍을 사용합니다. (NAF2는 리팩토링 중 성능 문제가 발견되어 재설계 중입니다.)

텍스트큐브 1.8은 텍스트큐브 1.7을 기반으로 새로운 환경에 대응하기 위한 텍스트큐브 2.0 이전의 버전입니다. 원래 예정되었던 텍스트큐브 2.0 로드맵 이전에 텍스트큐브 2.0이 설치되기 위한 제반 환경의 구축 및 홍보를 위한 버전입니다.

텍스트큐브 1.8은 1.7 코어의 하부 구조를 새로운 기반인 PHP 5.2 / MySQL 4.1의 기능을 충분히 활용하여 개선함과 동시에 대량 트래픽에 대한 대응 및 다양한 데이터베이스 지원과 텍스트큐브 2.0 프레임웍의 일부 테스트를 목표로 합니다.

주의사항

이 버전은 테스트를 위한 버전입니다. 관련한 인터페이스 및 코드 규격은 언제든지 변경될 수 있습니다. 또한 안정성에 대한 검증이 되지 않은 버전입니다. 실제 사용하는 블로그에는 적용하지 않는 것을 권장합니다.

업그레이드 하신 경우 반드시 블로그 주소 끝에 /checkup을 붙여서 데이터베이스 구조를 변경하시기 바랍니다. 그렇지 않으면 정상적으로 동작하지 않습니다.

또한 텍스트큐브 1.8은 PHP 5.2 이하의 버전에서 정상적으로 동작하지 않을 수 있습니다. 설치하는 서버의 PHP 버전이 5.2 이상인지 반드시 확인하시기 바랍니다.

텍스트큐브 1.8의 대부분의 기능 변경점과 버그 수정은 텍스트큐브 1.7.8에 백포트되어 선반영 된 상태입니다. 아래는 텍스트큐브 1.8에서 고유하게 변경된 내용입니다.

텍스트큐브 1.7.8 코어와 비교하여 텍스트큐브 1.8 beta 4에서 변경된 점은 다음과 같습니다.

  • 하부구조가 변경되었습니다. 업그레이드 형식으로 테스트할 경우 기존의 스킨이 보이지 않을 수 있습니다. 스킨을 포함한 구성요소들의 위치가 모두 변경되었습니다.
    • 블로그 스킨의 경우 /skin/blog 디렉토리로,
    • 관리 패널 스킨의 경우 /skin/admin 디렉토리로,
    • 카테고리 트리 스킨의 경우 /skin/tree 로 변경되었습니다.
    • 기존에 사용하시던 스킨은 해당되는 디렉토리로 이동해 주시기 바랍니다.
  • 언어팩 구조가 바뀌었습니다. 언어팩 위치는 /resources/locale 하위의 국가 코드 아래입니다. 부하를 줄이기 위하여 언어팩이 네 개로 분리되었습니다. 확인해 보시기 바랍니다.
  • memcached를 이용한 가속을 지원합니다. 이 기능을 사용하기 위해서는 서버 설정에서 memcache 사용을 체크하시면 됩니다. 기본값 이외의 memcached 설정을 위해서는 config.php에서 $memcached 변수를 통해 세부 사항을 지정할 수 있습니다. 가능한 값으로는 $memcached['port'], $memcached['server'] 값이 있습니다
  • memcached를 이용한 세션 핸들링을 지원합니다. memcache를 사용하는 경우 세션은 자동으로 memcache를 사용하도록 지정됩니다.
  • MySQLi를 사용한 데이터베이스 연결을 지원합니다. MySQLi를 지원하는 시스템에서는 자동적으로 MySQLi를 사용합니다.
  • Nginx 웹서버를 지원합니다. Nginx 웹서버는 러시아에서 개발된 가볍고 빠른 웹서버입니다. Nginx 웹서버와 fastCGI 의 조합 또한 지원합니다. 자세한 설치 방법은 배포판의 documents 하위의 nginx 관련 문서를 참고하시기 바랍니다.

아래는 변경사항 기록입니다.

more..

IIS / Nginx 웹서버 지원

텍스트큐브 1.7.6 이후의 버전은 IIS를 지원합니다. 또한 텍스트큐브 1.8부터 공식적으로 Nginx 웹서버의 설치를 지원합니다. 설치 및 설정에 관한 내용은 소스에 포함되어 있는 /documents/INSTALL 및 setup_nginx.txt 문서를 참고하시기 바랍니다..

스킨 치환자 추가

텍스트큐브 글 내에서 현재 글의 같은 카테고리 내의 최근 글을 출력하는 치환자가 두 개 추가 되었습니다. * [##_article_rep_category_rssurl_##] : 카테고리 RSS 의 링크입니다. * [##_article_rep_category_atomurl_##] : 카테고리 RSS 의 링크입니다.

또한 블로그 설정에서 카테고리 출력 부분에도 RSS 링크를 출력할 수 있는 옵션이 추가되었습니다. 이 옵션을 사용하기 위해서는 현재는 해당 카테고리 부분의 디자인이 스킨에 반영되어 있어야 합니다. 기본적으로 포함되어 있는 coolant 스킨의 디자인을 참조하시기 바랍니다.

피드백

테스트 중 개선에 대한 건의 사항이나 버그 보고는 태터 네트워크 재단 / 태터앤 프렌즈 포럼 의 아이디어 포럼이나 버그 보고 및 품질 검수 포럼으로 부탁 드립니다.

소스에 대하여 궁금하거나 변경사항을 추적하고 싶은 분들께서는 텍스트큐브 소스 내의 doc 디렉토리에 여러 문서들이 있으므로 참고하시기 바랍니다.

아래의 링크에서 다운로드 할 수 있습니다.

2009/06/24 01:16 2009/06/24 01:16

Posted by 텍스트큐브

이 글의 관련글(트랙백) 주소 : 이 글에는 트랙백을 보낼 수 없습니다
Comments
  1. 茂豬
    2009/06/24 10:03  PERMALINK  MODIFY/DELETE  REPLY

    加油,期待1.8的正式版.

  2. ^^
    2009/06/24 10:10  PERMALINK  MODIFY/DELETE  REPLY

    슬슬 빌드 버전이 올라가는군요..
    수고많으셨어요.

  3. 장세호
    2009/06/24 16:11  PERMALINK  MODIFY/DELETE  REPLY

    설치하려고 하면 아래와 같은 에러가 나네요.
    디렉토리 트리를 보면 library 디렉토리에 components라는 디렉토리가 없습니다.

    Warning: require_once(xxxxxxxxxx/tc/library/components/Needlworks.PHP.UnifiedEnvironment.php) [function.require-once]: failed to open stream: No such file or directory in xxxxxxxxxxx\tc\setup.php on line 37

    • 텍스트큐브
      2009/06/26 14:20  PERMALINK  MODIFY/DELETE

      다시 패키징한 버전을 올렸습니다. 프레임웍 이전 상황이 소스에 반영이 되지 않아서 발생한 문제입니다. 죄송합니다!

  4. 도아
    2009/06/25 08:39  PERMALINK  MODIFY/DELETE  REPLY

    수고 많으셨습니다. 다른 것은 혹하지 않는데 카테고리 RSS는 혹하게 하는군요. 고민입니다. 베타로 갈지 여기서 버틸지.

    테스트로 설치해 보니 문제가 많이 발생합니다. 먼저 점검을 하면 테이블 생성에 모두 실패합니다. 새로 설치하려고 하면 Needlworks.PHP.UnifiedEnvironment.php 파일이 없다고 나옵니다. Eolin.PHP.UnifiedEnvironment.php을 복사하면 Needlworks.PHP.Core.php가 없다고 나오고 이것 역시 Eolin으로 복사하면 Needlworks.PHP.Loader.php와 Needlworks.PHP.BaseClasses.php가 없다고 뜹니다.

    Needlworks.PHP.Loader.php와 Needlworks.PHP.BaseClasses.php를 텍스트큐브 개발 브랜치에서 내려받아 실행하면 로케일이 중복 선언되었다고 뜨는군요.

    Cannot redeclare class Locale in /home/gemulcom/gemul.net/html/framework/legacy/Needlworks.Core.Locale.php on line 8

    혹시나 싶어서 테스트용에 엎어 쒸우길 다행이라는 생각이 듭니다. 다만 관리자 UI가 바뀌었더군요. 패치 기다리겠습니다.

    • 텍스트큐브
      2009/06/26 14:21  PERMALINK  MODIFY/DELETE

      프레임웍을 이전하는 과정이 누락된 버전이 잘못 패키징 되었습니다. 수정한 버전을 업로드 하였습니다. 테스트에 번거로움을 끼쳐드려서 죙합니다-

    • 도아
      2009/06/26 17:15  PERMALINK  MODIFY/DELETE

      새로 받아도 테이블을 여전히 만들지 못하고 setup.php를 실행하면

      Notice: Constant ROOT already defined in /home/gemulcom/gemul.net/html/setup.php on line 10
      Warning: fopen(language/../description.php) [function.fopen]: failed to open stream: No such file or directory in /home/gemulcom/gemul.net/html/framework/legacy/Needlworks.Core.Locale.php on line 104
      Warning: fopen(language/./description.php) [function.fopen]: failed to open stream: No such file or directory in /home/gemulcom/gemul.net/html/framework/legacy/Needlworks.Core.Locale.php on line 104

      가 뜨며 언어를 가져오지 못합니다.

  5. Cybbie
    2009/06/27 11:32  PERMALINK  MODIFY/DELETE  REPLY

    there's no database.php in library......

    • 텍스트큐브
      2009/06/26 14:20  PERMALINK  MODIFY/DELETE

      패키징에 문제가 있었습니다. 수정한 버전을 다시 업로드 하였습니다. 죄송합니다~

  6. 매치어
    2009/07/02 16:30  PERMALINK  MODIFY/DELETE  REPLY

    베타버전이라 무척 조마조마했는데 예상보다 쉽게 설치할 수 있었습니다. 눈에 보이는 새로운 기능도 몇가지 보이네요. ^^ 새로운 관리자 패널 스킨이 1024*768 같은 좁은 해상도에선 제대로 안 보인다는 사소한 문제... 외엔 잘 쓰고 있는데 이상하게도 skin을 커스터마이징하고 저장하려고 하면 '권한이 없습니다'라고 나오네요. 전 단일블로그이고 /skin과 /skin/blog 모두 권한이 777이었는데 무슨 사연인지 모르겠습니다.

  7. Rukxer
    2009/07/03 21:19  PERMALINK  MODIFY/DELETE  REPLY

    이상한데.....설치가 아예 안 되네요.
    Fatal error: Cannot instantiate non-existent class: directoryiterator in /home/rukxer/public_html/setup.php on line 12
    사용 중인 호스팅 업체는 웹제로(www.webzero.kr)입니다.

    • 유마
      2009/07/06 12:43  PERMALINK  MODIFY/DELETE

      저만 안되는지 알았더니.... 다른 분도 안되시는군요.
      저는 cafe24.com 입니다..;;;;

    • Rukxer
      2009/07/06 13:24  PERMALINK  MODIFY/DELETE

      보니까.......제가 PHP4.x.x(기억이 가물;;)더라구요. 1.8 최소 요건이 PHP5.2인 듯 한데...
      웹제로에 얘기했더니 올 하반기에 업데이트 예정이긴 하답니다. 구체적인 예정은 없고 ㅡ.ㅡ;;
      기다려봐야겠네요 :-)

COMMENT*

Textcube 1.8 beta 3 공개

Category : 업데이트/테스트 버전
Reg Date : 2009/05/25 15:23
Textcube 1.8: Requiem

노무현 전 대통령님의 명복을 빕니다.

Textcube (이하 텍스트큐브) 1.8의 세번째 베타버전 (1.8.7523.20090525)을 공개합니다. 새 프레임웍 및 서비스 영역에 관련한 여러 문제로 인하여 텍스트큐브 1.8 alpha 8 이후 4개월동안 베타 트리의 업데이트가 현재까지 연기되었습니다.

텍스트큐브 1.8부터 도입 예정이었던 새 프레임웍인 NAF2 의 본격적인 도입은 텍스트큐브 2.0으로 연기되었으며, 텍스트큐브 1.8은 NAF2가 일부 반영되었지만 기존의 프레임웍과 호환성이 있는 NAF 호환 (1.5?) 프레임웍을 사용합니다. (NAF2는 리팩토링 중 성능 문제가 발견되어 재설계 중입니다.)

텍스트큐브 1.8은 텍스트큐브 1.7을 기반으로 새로운 환경에 대응하기 위한 텍스트큐브 2.0 이전의 버전입니다. 원래 예정되었던 텍스트큐브 2.0 로드맵 이전에 텍스트큐브 2.0이 설치되기 위한 제반 환경의 구축 및 홍보를 위한 버전입니다.

텍스트큐브 1.8은 1.7 코어의 하부 구조를 새로운 기반인 PHP 5.2 / MySQL 4.1의 기능을 충분히 활용하여 개선함과 동시에 대량 트래픽에 대한 대응 및 다양한 데이터베이스 지원과 텍스트큐브 2.0 프레임웍의 일부 테스트를 목표로 합니다.

주의사항

이 버전은 테스트를 위한 버전입니다. 관련한 인터페이스 및 코드 규격은 언제든지 변경될 수 있습니다. 또한 안정성에 대한 검증이 되지 않은 버전입니다. 실제 사용하는 블로그에는 적용하지 않는 것을 권장합니다.

또한 텍스트큐브 1.8은 PHP 5.2 이하의 버전에서 정상적으로 동작하지 않을 수 있습니다. 설치하는 서버의 PHP 버전이 5.2 이상인지 반드시 확인하시기 바랍니다.

텍스트큐브 1.8의 대부분의 기능 변경점과 버그 수정은 텍스트큐브 1.7.8에 백포트되어 선반영 된 상태입니다. 아래는 텍스트큐브 1.8에서 고유하게 변경된 내용입니다.

텍스트큐브 1.7.8 코어와 비교하여 텍스트큐브 1.8 beta 2에서 변경된 점은 다음과 같습니다.

  • 하부구조가 변경되었습니다. 업그레이드 형식으로 테스트할 경우 기존의 스킨이 보이지 않을 수 있습니다. 스킨을 포함한 구성요소들의 위치가 모두 변경되었습니다.
    • 블로그 스킨의 경우 /skin/blog 디렉토리로,
    • 관리 패널 스킨의 경우 /skin/admin 디렉토리로,
    • 카테고리 트리 스킨의 경우 /skin/tree 로 변경되었습니다.
    • 기존에 사용하시던 스킨은 해당되는 디렉토리로 이동해 주시기 바랍니다.
  • memcached를 이용한 가속을 지원합니다. 이 기능을 사용하기 위해서는 서버 설정에서 memcache 사용을 체크하시면 됩니다. 기본값 이외의 memcached 설정을 위해서는 config.php에서 $memcached 변수를 통해 세부 사항을 지정할 수 있습니다. 가능한 값으로는 $memcached['port'], $memcached['server'] 값이 있습니다
  • memcached를 이용한 세션 핸들링을 지원합니다. memcache를 사용하는 경우 세션은 자동으로 memcache를 사용하도록 지정됩니다.
  • MySQLi를 사용한 데이터베이스 연결을 지원합니다. MySQLi를 지원하는 시스템에서는 자동적으로 MySQLi를 사용합니다.
  • Nginx 웹서버를 지원합니다. Nginx 웹서버는 러시아에서 개발된 가볍고 빠른 웹서버입니다. Nginx 웹서버와 fastCGI 의 조합 또한 지원합니다. 자세한 설치 방법은 배포판의 documents 하위의 nginx 관련 문서를 참고하시기 바랍니다.

아래는 변경사항 기록입니다.

more..

IIS / Nginx 웹서버 지원

텍스트큐브 1.7.6 이후의 버전은 IIS를 지원합니다. 또한 텍스트큐브 1.8부터 공식적으로 Nginx 웹서버의 설치를 지원합니다. 설치 및 설정에 관한 내용은 소스에 포함되어 있는 /documents/INSTALL 및 setup_nginx.txt 문서를 참고하시기 바랍니다..

스킨 치환자 추가

텍스트큐브 글 내에서 현재 글의 같은 카테고리 내의 최근 글을 출력하는 치환자가 두 개 추가 되었습니다. * [##_article_rep_category_rssurl_##] : 카테고리 RSS 의 링크입니다. * [##_article_rep_category_atomurl_##] : 카테고리 RSS 의 링크입니다.

또한 블로그 설정에서 카테고리 출력 부분에도 RSS 링크를 출력할 수 있는 옵션이 추가되었습니다. 이 옵션을 사용하기 위해서는 현재는 해당 카테고리 부분의 디자인이 스킨에 반영되어 있어야 합니다. 기본적으로 포함되어 있는 coolant 스킨의 디자인을 참조하시기 바랍니다.

피드백

테스트 중 개선에 대한 건의 사항이나 버그 보고는 태터 네트워크 재단 / 태터앤 프렌즈 포럼 의 아이디어 포럼이나 버그 보고 및 품질 검수 포럼으로 부탁 드립니다.

소스에 대하여 궁금하거나 변경사항을 추적하고 싶은 분들께서는 텍스트큐브 소스 내의 doc 디렉토리에 여러 문서들이 있으므로 참고하시기 바랍니다.

아래의 링크에서 다운로드 할 수 있습니다.

2009/05/25 15:23 2009/05/25 15:23

Posted by 텍스트큐브

이 글의 관련글(트랙백) 주소 : 이 글에는 트랙백을 보낼 수 없습니다
Comments
  1. 하얀별
    2009/05/25 19:00  PERMALINK  MODIFY/DELETE  REPLY

    수고하셨습니다.

  2. Rukxer
    2009/05/27 12:55  PERMALINK  MODIFY/DELETE  REPLY

    수고하셨습니다!

  3. 축복
    2009/05/31 13:31  PERMALINK  MODIFY/DELETE  REPLY

    감사합니다 ^ㅡ^

  4. ilove
    2009/06/22 19:57  PERMALINK  MODIFY/DELETE  REPLY

    감사합니다.^^ 텍스트큐브를 이용해 http://blog.ilove.co.kr 에서
    무료로 블로그 배포하고 있습니다. 늘 감사드립니다.

COMMENT*

Textcube 1.8 beta 2 공개

Category : 업데이트/테스트 버전
Reg Date : 2009/05/07 18:22

Textcube (이하 텍스트큐브) 1.8의 두번째 베타버전 (1.8.7503.20090507)을 공개합니다. 새 프레임웍 및 서비스 영역에 관련한 여러 문제로 인하여 텍스트큐브 1.8 alpha 8 이후 4개월동안 베타 트리의 업데이트가 현재까지 연기되었습니다.

텍스트큐브 1.8부터 도입 예정이었던 새 프레임웍인 NAF2 의 본격적인 도입은 텍스트큐브 2.0으로 연기되었으며, 텍스트큐브 1.8은 NAF2가 일부 반영되었지만 기존의 프레임웍과 호환성이 있는 NAF 호환 (1.5?) 프레임웍을 사용합니다. (NAF2는 리팩토링 중 성능 문제가 발견되어 재설계 중입니다.)

텍스트큐브 1.8은 텍스트큐브 1.7을 기반으로 새로운 환경에 대응하기 위한 텍스트큐브 2.0 이전의 버전입니다. 원래 예정되었던 텍스트큐브 2.0 로드맵 이전에 텍스트큐브 2.0이 설치되기 위한 제반 환경의 구축 및 홍보를 위한 버전입니다.

텍스트큐브 1.8은 1.7 코어의 하부 구조를 새로운 기반인 PHP 5.2 / MySQL 4.1의 기능을 충분히 활용하여 개선함과 동시에 대량 트래픽에 대한 대응 및 다양한 데이터베이스 지원과 텍스트큐브 2.0 프레임웍의 일부 테스트를 목표로 합니다.

주의사항

이 버전은 테스트를 위한 버전입니다. 관련한 인터페이스 및 코드 규격은 언제든지 변경될 수 있습니다. 또한 안정성에 대한 검증이 되지 않은 버전입니다. 실제 사용하는 블로그에는 적용하지 않는 것을 권장합니다.

또한 텍스트큐브 1.8은 PHP 5.2 이하의 버전에서 정상적으로 동작하지 않을 수 있습니다. 설치하는 서버의 PHP 버전이 5.2 이상인지 반드시 확인하시기 바랍니다.

텍스트큐브 1.8의 대부분의 기능 변경점과 버그 수정은 텍스트큐브 1.7.8에 백포트되어 선반영 된 상태입니다. 아래는 텍스트큐브 1.8에서 고유하게 변경된 내용입니다.

텍스트큐브 1.7.8 코어와 비교하여 텍스트큐브 1.8 beta 2에서 변경된 점은 다음과 같습니다.

  • 하부구조가 변경되었습니다. 업그레이드 형식으로 테스트할 경우 기존의 스킨이 보이지 않을 수 있습니다. 스킨을 포함한 구성요소들의 위치가 모두 변경되었습니다.
    • 블로그 스킨의 경우 /skin/blog 디렉토리로,
    • 관리 패널 스킨의 경우 /skin/admin 디렉토리로,
    • 카테고리 트리 스킨의 경우 /skin/tree 로 변경되었습니다.
    • 기존에 사용하시던 스킨은 해당되는 디렉토리로 이동해 주시기 바랍니다.
  • memcached를 이용한 가속을 지원합니다. 이 기능을 사용하기 위해서는 서버 설정에서 memcache 사용을 체크하시면 됩니다. 기본값 이외의 memcached 설정을 위해서는 config.php에서 $memcached 변수를 통해 세부 사항을 지정할 수 있습니다. 가능한 값으로는 $memcached['port'], $memcached['server'] 값이 있습니다
  • memcached를 이용한 세션 핸들링을 지원합니다. memcache를 사용하는 경우 세션은 자동으로 memcache를 사용하도록 지정됩니다.
  • MySQLi를 사용한 데이터베이스 연결을 지원합니다. MySQLi를 지원하는 시스템에서는 자동적으로 MySQLi를 사용합니다.
  • Nginx 웹서버를 지원합니다. Nginx 웹서버는 러시아에서 개발된 가볍고 빠른 웹서버입니다. Nginx 웹서버와 fastCGI 의 조합 또한 지원합니다. 자세한 설치 방법은 배포판의 documents 하위의 nginx 관련 문서를 참고하시기 바랍니다.

아래는 변경사항 기록입니다.

more..

IIS / Nginx 웹서버 지원

텍스트큐브 1.7.6 이후의 버전은 IIS를 지원합니다. 또한 텍스트큐브 1.8부터 공식적으로 Nginx 웹서버의 설치를 지원합니다. 설치 및 설정에 관한 내용은 소스에 포함되어 있는 /documents/INSTALL 및 setup_nginx.txt 문서를 참고하시기 바랍니다..

피드백

테스트 중 개선에 대한 건의 사항이나 버그 보고는 태터 네트워크 재단 / 태터앤 프렌즈 포럼 의 아이디어 포럼이나 버그 보고 및 품질 검수 포럼으로 부탁 드립니다.

소스에 대하여 궁금하거나 변경사항을 추적하고 싶은 분들께서는 텍스트큐브 소스 내의 doc 디렉토리에 여러 문서들이 있으므로 참고하시기 바랍니다.

아래의 링크에서 다운로드 할 수 있습니다.

2009/05/07 18:22 2009/05/07 18:22

Posted by 텍스트큐브

이 글의 관련글(트랙백) 주소 : 이 글에는 트랙백을 보낼 수 없습니다
Comments
  1. 도아
    2009/05/07 23:44  PERMALINK  MODIFY/DELETE  REPLY

    고생 많으셨습니다. 이제 조만간 1.8이 나오겠군요. 다만 폴더 구조가 변경되서 베타판에서 선뜻 업하기 힘들것 같습니다.

  2. golden
    2009/05/09 07:12  PERMALINK  MODIFY/DELETE  REPLY

    백업시 첨부파일이 누락되고 있습니다.

COMMENT*
  *1   *2   *3   *4   *5