Textcube 1.8.2 : Secondary Dominant 공개

Category : 업데이트/안정 버전
Reg Date : 2010/01/31 18:21

Textcube (이하 텍스트큐브) 1.8.2 : Secondary Dominant (r24, 1.8.8385.20100131) 를 공개합니다.

알림 : Textcube 1.8.2는 텍스트큐브 1.8, 1.8.0.1, 1.8.1 의 동작 안정화에 관련한 필수적인 업데이트를 포함하고 있습니다. 텍스트큐브 1.8 사용자 분들께서는 가급적이면 무조건 업데이트 하시기를 권장합니다.

텍스트큐브 1.8은 텍스트큐브 1.7을 기반으로 새로운 환경에 대응하기 위하여 하부 구조를 재설계하는 첫 버전입니다.

텍스트큐브 1.8은 1.7 코어의 하부 구조를 새로운 기반인 PHP 5.2 / MySQL 4.1의 기능을 충분히 활용하여 개선함과 동시에 대량 트래픽에 대한 대응 및 다양한 데이터베이스 지원과 텍스트큐브 2.0 프레임웍의 일부 테스트를 목표로 합니다.

텍스트큐브 1.8.2 발표후보 1로부터의 업데이트

이미 텍스트큐브 1.8.2 발표후보 1을 사용하시는 분들께서는 1.8.2를 내려받으신 후 전체를 덮어 씌울 필요 없이 아래의 파일만 업데이트하시면 됩니다.

  • interface/blog/checkup.php
  • interface/owner/entry/preview/index.php
  • documents/changelog_ko.txt
  • library/model/blog.notice.php
  • library/config.default.php
  • resources/style/setup/style.css
  • resources/image/icon_favicon_default.ico
  • framework/legacy/Textcube.Data.SkinSetting.php
  • framework/alias/POD.php
  • framework/alias/DBAdapter.php
  • framework/data/PostgreSQL/Adapter.php

텍스트큐브 1.8.1 로부터의 업데이트

텍스트큐브 1.8.1을 사용하시는 분들께서는 1.8.2를 내려받으신 후 전체를 덮어 씌울 필요 없이 아래의 파일을 업데이트하시면 됩니다.

아래의 파일 목록이 너무 많아 보이시는 분들께서는 diff 파일을 내려 받아 patch 프로그램으로 업데이트 할 수 있습니다. 단 이 경우, 텍스트큐브 코어 패키지만 업데이트 되므로, 기존에 확장팩을 설치하신 분들께서는 패치 후 확장팩을 내려받아 플러그인 디렉토리 (/plugins) 를 덮어 씌우시기 바랍니다.

파일 목록 보기...

텍스트큐브 1.8 관련 문서

업그레이드 시 주의사항

more..

변경사항 기록 (1.8.1 - 1.8.2)

more..

변경사항 기록 (1.8.0.1 ~ 1.8.1)

more..

변경사항 기록 (1.7 ~ 1.8.0)

more..

피드백

테스트 중 개선에 대한 건의 사항이나 버그 보고는 태터 네트워크 재단 / 태터앤 프렌즈 포럼 의 아이디어 포럼이나 버그 보고 및 품질 검수 포럼으로 부탁 드립니다.

소스에 대하여 궁금하거나 변경사항을 추적하고 싶은 분들께서는 텍스트큐브 소스 내의 documents 디렉토리에 여러 문서들이 있으므로 참고하시기 바랍니다.

아래의 링크에서 다운로드 할 수 있습니다.

아래는 patch를 사용하여 적용할 수 있는 diff 파일입니다. 텍스트큐브 코어 패키지만 업데이트 되므로, 기존에 확장팩을 설치하여 사용중이신 분들께서는 패치 후 확장팩을 내려받아 플러그인 디렉토리 (/plugins) 를 덮어 씌우시기 바랍니다

2010/01/31 18:21 2010/01/31 18:21

Posted by 텍스트큐브

이 글의 관련글(트랙백) 주소 : 이 글에는 트랙백을 보낼 수 없습니다
  • Tracked from : 半長의 생각들과 기타 잡스러운... 2010/02/02 15:57 DELETE
    Subject : 텍스트큐브 1.8.2로 업그레이드

    기존 1.7.8 버전의 텍스트큐브에서 텍스트큐브 1.8.0.1로 업그레이드 한 후 초고속으로 다시 텍스트큐브 1.8.1로 업그레이드 한 지 그리 오래 되지 않은 것 같은데, 안정성이 강화된 1.8.2 버전 이 나와 또 다시 바로 업그레이드 했다. 그리고 이번 업그레이드 역시 그 결과(속도, 안정성 등)에 아주 만족하고 있다. 텍스트큐브 업그레이들 위해 힘 써주시는 모든 분들께만 해당 막간을 이용, 텍스트큐브 업그레이드를 위해 애쓰시는 모든 분들께 ...

Comments
  1. 손님
    2010/01/31 21:00  PERMALINK  MODIFY/DELETE  REPLY

    슬슬 업글할시기가 된건지..1.7.9 버전 이용중인데..ㅠㅠ

  2. 밀피유
    2010/01/31 22:16  PERMALINK  MODIFY/DELETE  REPLY

    다운로드 링크가 모두 깨져있습니다. 확인 부탁드려요.

    • 텍스트큐브
      2010/02/01 13:56  PERMALINK  MODIFY/DELETE

      방금 확인했습니다. 이번 버전부터 patch를 위한 diff도 함께 제공하는데, 다운로드쪽에서 명령을 처리하는 프로그램의 오류였습니다. 방금 수정했습니다.

      알려주셔서 감사합니다.^^

  3. 지우개
    2010/02/01 10:14  PERMALINK  MODIFY/DELETE  REPLY

    밀피유님 말씀처럼 링크가 깨졌군요 ㅠㅠ*

  4. 나비
    2010/02/01 13:52  PERMALINK  MODIFY/DELETE  REPLY

    그러네요.. 링크가 다 깨져서 404에러~~

    • 텍스트큐브
      2010/02/01 13:57  PERMALINK  MODIFY/DELETE

      동작되도록 고쳤습니다. 이번 버전부터는 diff 파일을 제공하니 혹시 patch 를 사용할 줄 아신다면 기존의 1.8.1을 바로 패치할 수도 있습니다^^

  5. 도아
    2010/02/01 15:39  PERMALINK  MODIFY/DELETE  REPLY

    저는 1.8.2 RC까지 로그인을 못하고 있습니다. 처음에는 DB 오류로 생각했는데 디버그 모드에서 보면 쿠키가 설정되지 않는 듯 로그인이 풀리더군요. 쿠키 설정까지 모두 확인해봤지만 아직까지 해결하지 못해 업을 못하고 있습니다. 요즘은 나이를 먹어서 그런지 원인을 찾기도 귀찮더군요. 아무튼 빨리 원인을 찾아 판올림해야 겠습니다. 수고 많으셨습니다.

    • 텍스트큐브
      2010/02/01 23:29  PERMALINK  MODIFY/DELETE

      혹시 1.8.2에서도 로그인이 안 되신다면, /library/preprocessor.php 의 151, 152번째 줄을 주석처리하고 한 번 테스트 부탁 드립니다. 쿠키 정보를 변조하는 서버들을 위한 코드가 추가되어 들어가 있는데, 혹시 이 코드가 문제를 만들 수도 있을 것 같아서요^^

      만약 업그레이드의 경우라면 체크업을 강제로 해서 세션 테이블 구조를 바꾸어야 그 다음에 로그인이 가능합니다. 한 번 확인 부탁드립니다~

    • 도아
      2010/02/15 10:07  PERMALINK  MODIFY/DELETE

      감사합니다. Checkup은 처음 판올림을 하면서 실행했습니다. 따라서 다시 해도 OK가 떨어집니다. 또 151,152행을 주석처리해도 결과는 같은 결과가 뜨는군요. 또 세션 테이블을 보면 같은 아이디의 세션이 계속 추가되는 군요.

  6. 시렌
    2010/02/01 19:35  PERMALINK  MODIFY/DELETE  REPLY

    1.8.1에서 1.8.2로 업데이트할 때 복사해야하는 파일 목록을 보면 skin/admin/mobile 폴더에 있는 파일들이 있어요. 그런데 기본 패키지 (.zip), 기본 패키지 (.tar.gz), 확장 패키지 (.zip), 확장 패키지 (.tar.gz) 전부 관련 폴더와 파일들이 없습니다.

    • ko@tattersite.com
      2010/02/01 23:26  PERMALINK  MODIFY/DELETE

      아, 해당 파일들은 원래 없습니다; 1.8.3에 들어가는 파일들인데, 잘못 적혔습니다. 죄송합니다. ㅠ_ㅠ

  7. 其仁
    2010/02/02 15:58  PERMALINK  MODIFY/DELETE  REPLY

    언제나 감사드립니다. 잘 사용하겠습니다.

  8. jinugoon
    2010/02/06 22:43  PERMALINK  MODIFY/DELETE  REPLY

    1.8.0 에선 문제 없다가 1.8.2 로 업데이트 하고 나니
    글을 쓰고 저장한 후에 "저장하지 못했습니다" 로 표시되네요. ( 메시지만 이렇게 나오고 글이 저장되긴합니다만 오류가 있는것 같아..찜찜하네요) 방법이 없을까요?

    • 텍스트큐브
      2010/02/07 12:22  PERMALINK  MODIFY/DELETE

      혹시 디버그 모드를 켜 놓은 상태이지는 않으신지요? 확인 부탁 드립니다^^

    • jinugoon
      2010/02/11 21:29  PERMALINK  MODIFY/DELETE

      디버그 설정이 되있지는 않습니다.
      한번도 디버그 모드를 쓴적은 없어서 그게 이유는 아닌것 같아요.ㅠ

    • 텍스트큐브
      2010/02/21 04:40  PERMALINK  MODIFY/DELETE

      플러그인 중 오류 메세지를 내보내는 플러그인이 있다면, 그 플러그인이 글 저장후 뱉어내는 경고 문구 때문에 저장 성공 여부의 판단이 영향을 받을 수 있습니다. 한 번 확인해보세요^^

  9. 인게이지
    2010/02/09 18:35  PERMALINK  MODIFY/DELETE  REPLY

    여전히 이전 안되는 댓글 알리미와 받은 트랙백...
    대체 언제 고칠건지....

    • 텍스트큐브
      2010/02/21 04:41  PERMALINK  MODIFY/DELETE

      되는 경우와 안되는 경우들을 구분하고 있습니다... 1.8.3에서는 고쳐져서 나갈 예정입니다^^

  10. Glradios
    2010/02/17 18:48  PERMALINK  MODIFY/DELETE  REPLY

    모블로그 관리 기능은 언제부터 활성화 되나요? ^^

  11. Gunmania
    2010/03/02 20:35  PERMALINK  MODIFY/DELETE  REPLY

    1.7.8에서 업글하고싶은데 호스팅에서 일단 사양 문제는 없는데 권한문제로 안깔려서 못쓰고 있네요 쩝

  12. i-on-i
    2010/03/06 02:48  PERMALINK  MODIFY/DELETE  REPLY

    1.78버전에서 1.82로 업그래이드 했다고 제 블로그 싸이트 주소만 치면 스킨이 존재하지 않는다는 에러가 계속나와서 결국 다시 1.78로 갈아탔습니다. 뭐가 문제일까요? 덮으쓰고 해야할것 다 한것 같은데 제 블로그에 들어갈 수 조차 없으니 뭐 그림의 떡이군요..ㅜ.ㅜ

    • inureyes
      2010/03/09 23:19  PERMALINK  MODIFY/DELETE

      스킨 디렉토리의 위치가 변했습니다. 기존에는 /skin 하위인데, 그게 /skin/blog 하위로 바뀌었습니다. 기존에 사용중이신 스킨이 있다면 /skin에서 /skin/blog 으로 위치를 옮기셔야 합니다^^

COMMENT*
  *1   ... *86   *87   *88   *89   *90   *91   *92   *93   *94   ... *280